
Welcome to PCoIP Software Client for Windows

Welcome to the Teradici PCoIP® Software Client for Windows Administrators' Guide.

PCoIP Software Clients are applications that establish PCoIP sessions with remote Windows or

Linux desktops. Connections can be made remote desktops and workstations via either PCoIP

Agents (component of Cloud Access Software) or Remote Workstation Cards.

This guide explains how to install, configure, and use the PCoIP Software Client for Windows. It

includes client system requirements and information on host dependencies.

Welcome to PCoIP Software Client for Windows
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Who Should Read This Guide?

This guide is intended for administrators and users who install, configure, or use the Teradici

PCoIP® Software Client for Windows.

Understanding terms and conventions in Teradici guides

For more information on the industry specific terms, abbreviations, text converntions, and graphic symbols used in

this guide, see Using Teradici Product and Component Guides and the Teradici Glossary.



Who Should Read This Guide?
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What's New in This Release

The PCoIP Software Client for Windows 20.04 introduces the following features and

enhancements:

Local Termination of Wacom Cintiq 22HD, Intuos Pro S and Cintiq Pro 32

This release of the PCoIP Software Client for Windows 20.04 supports local termination with the

Intuos Pro Small (PTH-460), Cintiq 22HD (DTK-2200) and Cintiq Pro 32 (DTH-3220). For more

information, see Wacom Tablets.

Override Local Termination of Wacom Tablets

Local Termination of Wacom tablets provides the best user experience in networks with high

latency, however some features of the tablet may not be fully supported with local termination. A

HID Local Termination Blacklist has been added to override the preferred local termination mode.

Devices on the blacklist would be bridged to the remote desktop. For more information, see Local

Termination Blacklist.

High Performance Client

This release of the Software Client for Windows 20.04 includes the ability to enable the high

performance mode of the PCoIP Client which facilitates an increased frame rate. For more

information, see High Performance Client.

Security and Stability Updates

Increased security and stability updates and enhancements around the PCoIP Client.

What's New in This Release
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Additional Documentation

The following guides contain additional information relevant to PCoIP systems and PCoIP

Software Clients:

• For more information about Teradici Cloud Access Software, including detailed information on

included PCoIP components as well as Teradici All Access plans, see the Teradici Cloud

Access Architecture Guide.

• For more information about Teradici PCoIP agents, which are required on remote virtual

machines, see the following pages:

• Teradici PCoIP Standard Agent for Windows

• Teradici PCoIP Graphics Agent for Windows

• Teradici PCoIP Standard Agent for Linux

• Teradici PCoIP Graphics Agent for Linux

• For information about Teradici PCoIP Host Software, which is required on remote

workstations using a Teradici PCoIP Remote Workstation Card, see the following pages:

• PCoIP Host Software for Windows

• PCoIP Host Software for Linux

Additional Documentation
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System Requirements

The following table outlines the system requirements for the PCoIP Software Client for Windows:

*Only required when connecting to PCoIP Remote Workstation Cards.

System Version Required

PCoIP Software Client Operating Systems
• Windows 10 (64-bit)

Compatible PCoIP agents All PCoIP agents and versions

Compatible PCoIP Remote Workstation Cards TERA22x0 with firmware 5.0.1+. The Software Clients are

only compatible with the latest RWC firmware for brokered

connections. Direct Connect will still work with older

firmware versions.

Customers may still connect to a non-brokered

PCoIP Remote Workstation Card by connecting to

the FQDN of the workstation instead of the PCoIP

Remote Workstation Card.

Compatible PCoIP Host Software*
• Remote Workstation Card Software for Windows:

20.01

• Remote Workstation Card Software for Linux: 20.01

System Requirements
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Audio Support

Stereo audio output and mono audio input are supported and enabled by default.

The PCoIP Client provides an enhanced audio and video synchronization (A/V Sync) feature that

provides improved full-screen video playback, reducing the difference in delays between the audio

and video channels and smoothing frame playback on the client. This improves lip sync and

reduces video frame drops for movie playback. This feature introduces a small lag in user

interaction responsiveness when enabled. Using enhanced audio and video synchronization will

reduce the maximum frame rate.

For more information on the A/V Sync feature, see Enhanced Audio and Video Synchronization.

Audio Support
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Displays

The PCoIP Client supports a maximum of four displays and a maximum resolution of 4K UHD

(3840×2160).

Monitors can be arranged in a vertical line, a horizontal line, or as a 2×2 box display. They can be

used in any standard rotation (0°, 90°, 180°, or 270°), with any monitor as the primary display.

Note: Using multiple high-resolution displays

Systems with multiple high-resolution displays, such as quad 4K UHD topologies, require powerful system

infrastructure. Be sure to use a system with sufficient bandwidth and client capability to support your required display

topology.



Important: Attaching monitors to the host machine in not supported

PCoIP client supports a maximum of four displays. Attaching extra monitors to the host machine will conflict with

client display topologies.



Displays
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Supported Installer Languages

The PCoIP Client installer supports the following languages:

• French

• German

• Spanish

• Simplified Chinese

• Traditional Chinese

• Japanese

• Portuguese

• Italian

• Korean 

• Russian

• Turkish

Supported Installer Languages
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PCoIP Ultra

The PCoIP Client provides support for PCoIP Ultra, the latest protocol enhancements from

Teradici. PCoIP Ultra is optimized for truly lossless support with bit-exact color accuracy and

preservation of content detail at the highest frame rates.

PCoIP Ultra protocol enhancements propels our industry-recognized performance into the future

of remote computing, with faster, more interactive experience for users of remote workstations

working with high-resolution content.

PCoIP Ultra enhancements are controlled on the PCoIP Agent. There is no configuration required

on the PCoIP Client.

When to Enable PCoIP Ultra

In release 20.01, PCoIP Ultra supports the following use cases:

• Users requiring CPU-optimized delivery of 4K UHD, high-framerate video playback.

• Efficient scaling across multicore CPUs, leveraging AVX2 instruction sets.

For all other scenarios, Teradici recommends that you leave PCoIP Ultra disabled. For additional

detail on PCoIP Ultra technical requirements for various use cases and troubleshooting steps, refer

to KB 2109: PCoIP Ultra Troubleshooting.

Requirements

To take advantage of PCoIP Ultra, you need:

• A PCoIP Agent (any type), 19.11 or later

PCoIP Ultra is appropriate for specific use cases

For most users, the default PCoIP protocol will provide the best possible experience. Carefully review the

recommended use cases in the next section to determine whether you should enable it.



PCoIP Ultra
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• A PCoIP Software Client (any type), 19.11 or later

• The CPUs on both the agent and the client machines must support the AVX2 instruction set.

Enabling PCoIP Ultra

In order to enable PCoIP Ultra features you need to turn on GPO variables. For information on

enabling this with Linux, see Enabling PCoIP Ultra for Linux. For information on enabling this with

Windows, see Enabling PCoIP Ultra for Windows. 

PCoIP Codec Indicator

When enabling PCoIP Ultra there will be an onscreen indicator at the bottom left corner of the

screen. PCoIP Ultra CPU optimization is indicated with a dark blue dot. PCoIP Ultra GPU

optimization is indicated by a magenta dot. To disable this codec indicator create the following

registry key and set to 0: 

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Teradici\PCoIP\pcoip_admin_defaults\

pcoip.codec_indicator (DWORD)

Enabling PCoIP Ultra
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Printing Support

When a local printer is visible to a client computer by USB connection or local network connection,

it may be possible to print from the host machine. Refer to the following table for local printing

support.

Cloud printing is available from all clients if supported by the desktop system and correct PCoIP

Agent.

The PCoIP Standard Agent for Linux does not support local printing on remote clients.

Local, network, and cloud printers are supported in various ways:

• Linux hosts can print to any printer on the host machine’s local area network.

• If your host host workstation has access to the Internet, cloud-based printing is supported

through cloud-printing services such as Google Cloud Print and HP Mobile Printing.

PCoIP Agent for Windows PCoIP Agent for Linux

Local USB Printing  

printer is connected to a USB port on the client computer

—

Local Network Printing  —

Cloud Printing  —

Printing Support
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USB Support

PCoIP Clients supports redirecting USB devices to a remote session. Administrators can set rules

governing allowed and disallowed devices, device classes, or device protocols. 

Isochronous USB device support

USB devices with time-sensitive information, such as webcams, are not generally supported.

However, Teradici's technology partners provide additional solutions to expand peripheral support

such as webcams. For more information, look for partners listed under Peripherals on the Teradici

Technology Partners page.

Important: USB support is enabled by default

USB bridging is enabled by default. If you want to restrict or disable USB support, you can globally disable or set rules

governing USB behavior via GPO settings on the PCoIP Agent.



USB Support
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Wacom Tablet Support

The Software Client for Windows supports Wacom tablets in two configurations: bridged, where

peripheral data is sent to the desktop for processing, and locally terminated, where peripheral data

is processed locally at the Software Client.

Locally terminated Wacom tablets are much more responsive and tolerate low latency

connections. 

Whether the Wacom tablet is locally terminated or bridged, the process of remoting the USB

device is the same, you need to click connect in the USB menu or auto forward the device. If local

termination is supported for the particular device, it will automatically be chosen over bridging. For

more information on this, see Local Termination Blacklist.

Locally Terminated Wacom Tablets

Locally-terminated tablets have greatly improved responsiveness, and tolerate higher-latency

(including 25ms and higher) networks.

Local termination requires:

• A Standard agent or Graphics agent for Windows version 19.11 or higher.

• A Standard agent or Graphics agent for Linux version 19.11 or higher.

The following Wacom tablet models have been tested and are supported with local termination.

PCoIP client support for locally terminated Wacom tablets and the Software Client for Windows

PCoIP

Standard

Agent for

Linux

PCoIP

Graphics

Agent for

Linux

PCoIP

Standard

Agent for

Windows

PCoIP

Graphics

Agent for

Windows

PCoIP Remote

Workstation

Card

Intuos Pro Small

PTH-460

    —

Wacom Tablet Support
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Bridged Wacom Tablets

Bridged Wacom tablets are supported only in low-latency environments. Tablets in network

environments with greater than 25ms latency will show reduced responsiveness and are not

recommended. A HID Local Termination Blacklist has been added to override the preferred local

termination mode. Devices on the blacklist would be bridged to the remote desktop. For more

information, see Local Termination Blacklist.

The following Wacom tablet models have been tested and are supported on a PCoIP Software

Client for Windows.

PCoIP

Standard

Agent for

Linux

PCoIP

Graphics

Agent for

Linux

PCoIP

Standard

Agent for

Windows

PCoIP

Graphics

Agent for

Windows

PCoIP Remote

Workstation

Card

Intuos Pro Medium

PTH-660

    —

Intuos Pro Large

PTH-860

    —

Cintiq 22HD

DTK-2200

    —

Cintiq Pro 24 -

 Pen Only

DTK-2420

    —

Cintiq 22HDT -

 Pen & Touch

DTH-2200

— — — — —

Cintiq Pro 24 -

 Pen & Touch

DTH-2420

— — — — —

Cintiq Pro 32 -

 Pen & Touch

DTH3220

    —

Bridged Wacom Tablets

© 2020 Teradici 14



PCoIP client support for bridged Wacom tablets and the Software Client for Windows

PCoIP

Standard

Agent for

Linux

PCoIP

Graphics

Agent for

Linux

PCoIP

Standard

Agent for

Windows

PCoIP

Graphics

Agent for

Windows

PCoIP Remote

Workstation

Card

Intuos Pro Small

PTH-460

    —

Intuos Pro Medium

PTH-660

    —

Intuos Pro Large

PTH-860

    —

Cintiq 22HD

DTK-2200

    —

Cintiq Pro 24 -

 Pen Only

DTK-2420

    —

Cintiq 22HDT -

 Pen & Touch

DTH-2200

    —

Cintiq Pro 24 -

 Pen & Touch

DTH-2420

    —

Cintiq Pro 32 -

 Pen & Touch

DTH3220

    —

Bridged Wacom Tablets
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Known Issues with Wacom Tablets and Functionality

Whilst testing and developing the compatibility of Teradici Cloud Access Software with different

Wacom tablets, certain performance issues arise. The following is a list of the current known

issues with certain Wacom tablets:

• The touch feature does not work on any supported device for both bridged and locally

terminated devices across all platforms.

• ExpressKey Remote does not work on the Wacom Cintiq Pro 32 (DTH-3220). You should still

remote to this device when remoting to the Wacom tablet.

• There are cursor limitations when working with the Wacom Cintiq 22HD (DTK-2200) and

Wacom Cintiq Pro 24 (DTK-2420) for both bridged and locally terminated devices across all

platforms.

• There is a issue with the control buttons on the Wacom Cintiq Pro 32 (DTH-3220) device. The

buttons do not function on locally terminated devices across all platforms.

• For Wacom Cintiq 22HD (DTK-2200) there is a known issue in the latest Wacom driver that

can cause complications when locally terminated. If you are using the Wacom Cintiq 22HD

(DTK-2200) and connecting to a Windows Agent, you should downgrade the driver on the

PCoIP Agent to 6.3.32-4.

• PCoIP Clients are not compatible with NoMachine and No Machine USB drivers. For

information on how to uninstall NoMachine USB drivers, see here.

Wacom Cintiq Pro 32 Tablet Selection

The Wacom Cintiq Pro 32 shows up as multiple devices in the USB menu. You should remote the

following USB devices as outlined in the image below to remote to this Wacom tablet:

• ExpressKey Remote

• Cintiq Pro 32 Touch

• Wacom Cintiq Pro 32

Known Issues with Wacom Tablets and Functionality
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Wacom Cintiq Pro 32 Tablet Selection
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Relative Mouse Support

Relative mouse support enables relative rather than absolute coordinates, often required for

example in CAD design.

This feature is currently supported with the following components:

The following components do not support this feature:

• PCoIP Standard Agent for Linux

• PCoIP Graphics Agent for Linux 

Enabling Relative Mouse Support

To enable relative mouse support create a pcoip_client_settings.txt file in %localappdata%

\Teradici and run the following command:

Relative Mouse Support Supported

PCoIP Software Client for Windows 

PCoIP Software Client for Linux 

PCoIP Tera2 Zero Client 6.4 (Requires Configuration to enable) 

PCoIP Standard Agent for Windows 

PCoIP Graphics Agent for Windows 

pcoip.enable_relative_mouse=1

Relative Mouse Support
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Installing the Software Client for Windows

In this section, you will learn how to install and uninstall the Software Client for Windows for

Windows.

Before You Begin

Before installing the Software Client for Windows:

• You must be logged in as an administrator to the client machine.

• Close any existing Software Client for Windows applications.

Installing the Software Client

You can install the Software Client for Windows with the provided Windows installation wizard or

from the command line.

To install the Software Client for Windows using the wizard:

1. Double-click the Software Client for Windows installer executable (pcoip-client.exe) to begin

installation.

2. Follow the prompts to specify installation locations, and to agree to any licenses.

3. Click Finish to complete installation and close the installer.

To install the Software Client for Windows silently from the command line:

• Install the Software Client for Windows silently by running the installer executable from the

command line:

Microsoft Visual C++ Redistributable package

The libraries in this package are required by the Software Client for Windows. If they aren't already installed, a

wizard will launch and install them for you.



Installing the Software Client for Windows
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where  is the full path to the folder containing the pcoip-client.exe

executable.

Uninstalling the Software Client

To uninstall the Software Client for Windows:

1. Click Start (or Search Windows for Windows 10).

2. In the search box, type Add or remove programs and press Enter.

3. Select Teradici PCoIP Client from the list of programs.

4. Click the Uninstall/Change button above the list.

<path-to-installer>\pcoip-client.exe /S`

<path-to-installer>

Silent installation uses default options

The silent installer uses default settings and options. For example, a silent installation won't create a desktop

shortcut.



Uninstalling the Software Client
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Using the PCoIP Software Client

After installing a PCoIP Software Client on your client machine, you can connect to the following

PCoIP solutions or products or hosts:

• Teradici PCoIP Graphics Agent or PCoIP Standard Agent installed as part of Teradici Cloud

Access Software.

• Teradici PCoIP Remote Workstation Card and Teradici PCoIP Host Software installed in a

Windows or Linux workstation.

Using the PCoIP Software Client
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Connecting to Virtual Machines

You can connect to virtual Windows or Linux hosts that have a PCoIP Standard Agent or PCoIP

Graphics Agent installed. Connections can be made directly to individual host machines, or via a

connection broker in managed deployments.

To connect to a remote workstation or virtual desktop:

1. Double-click the PCoIP Client desktop icon, alias, or program file PCoIPClient to launch the

application.

2. In the Host Address or Code field, enter one of the following:

• For direct connections, provide the address of the host machine.

• For managed connections, provide the address of the connection manager. 

If you want to save this connection later for easy recall, enter a name in the Connection Name

field. You will save the connection in step 5.

3. Click NEXT.

Connecting to Virtual Machines
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4. On the next screen, select your domain from the dropdown list, enter your user name and

password for the desktop, and then click LOGIN. 

About the Security Padlock Indicator

The login screen displays a red padlock indicator when accessing a PCoIP agent desktop that uses default self-

signed certificates. The icon indicates that the software’s certificate is not signed by a trusted certificate

authority (CA). You can use your own CA to create a certificate and then install the appropriate files at each end.

If the client trusts your internal CA, a green padlock icon displays on the screen instead. To learn more about

certificates, see the PCoIP agent administrators guides listed in the Teradici Cloud Access Architecture Guide.



To connect to a remote workstation or virtual desktop:
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5. If your login is successful, the following screen appears with a list of available desktops: 

6. Click Connect to connect to the selected desktop.

A short interface delay is normal

When a session is first connected, it may take a few seconds before you can take control of the keyboard and mouse.

This is normal behavior.



Single-desktop users

If a user only has access to a single desktop, that desktop is automatically selected and the connection is initiated

immediately. These users are not presented with a desktop selection screen.



To connect to a remote workstation or virtual desktop:
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Advanced Saved Connections

Administrators can save more complex desktop connections with the PCoIP Client. The following

section outlines the connection scenarios that can be saved, and outlines the potential benefits of

doing so.

Saved Broker Address

This configuration enables you to create a saved connection where only the broker address is

saved. You need to enter your username when connecting to a remote host. Enter the host

address and name the connection, then click SAVE.

Pre-configured connections

This partial save feature enables administrators to pre-configure connection information as a saved connection and

bundle it with the client application. For example, administrators can save a connection with the FQDN of the PCoIP

Connection Manager preset and then distribute this information to their deployed clients. As a result of this users

would be able to skip past the initial domain screen and advance directly to their user authentication screen.

The administrator can find and distribute the connection info file located at %APPDATA%\Teradici\PCoIP Client 

Connection Info.ini



Advanced Saved Connections
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Multiple Desktops

This configuration enables you to see and access a selection of desktop environments each time

you connect. 

1. Enter the host address and name the connection 

2. Enter and save the Username 

Multiple Desktops
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Once you have done this each time you use this connection you will be presented with the list of

available desktops for that connection. 

Multiple Desktops
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Connecting to Teradici PCoIP Remote Workstation
Cards

You can connect to remote workstations with a Teradici PCoIP Remote Workstation Card and

PCoIP Host Software installed. Refer to System Requirements for supported versions.

Initial Workstation Configuration

Before you can connect to your remote workstation for the first time, a few things must be

configured on the host machine.

These configuration actions only need to be taken once on each remote workstation in your

system:

• Enable monitor emulation for the video ports on your remote workstation

If monitor emulation is not enabled, you may see blank gray screens when you connect from

the PCoIP Software Client.

To enable monitor emulation, log in to the card’s Administrator Web Interface (AWI) and select

Enable Monitor Emulation on Video Port n from the Configuration > Monitor Emulation menu.

For more information, see the Tera2 PCoIP Zero Client Firmware 4.x and Remote Workstation

Card Firmware 4.9 Administrators' Guide.

• Disable temporal dithering

Temporal dithering causes blurriness, heavy packet loss, and high CPU usage on the PCoIP

Software Client machine. See Should I disable the dithering feature of my graphics card in a

remote workstation environment? (KB 15134-207) for more information.

• Linux workstations: configure PCoIP Host Software to Start Automatically

To configure the PCoIP host software to start automatically, log into the workstation using a

PCoIP Zero Client or directly from a local mouse and keyboard, and modify the workstation

startup script to launch the PCoIP host software. For details, see Installing PCoIP Host

Software Binary RPM in the PCoIP® Host Software for Linux User Guide.

Connecting to Teradici PCoIP Remote Workstation Cards
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Connecting to a Remote Workstation Card

Once the remote workstation is properly configured, you can connect to it from the PCoIP

Software Client.

Direction Connection to a Remote Workstation Card

The direct connection from the PCoIP Software Client to the PCoIP Remote Workstation Card is

supported through the PCoIP Remote Workstaton Agent software which needs to be installed on

the workstation where the PCoIP Remote Workstation Card is installed. Both the NIC of the

workstation and the Remote Workstation Card need to be connected to the same network switch.

When establishing a connection, the PCoIP Software Client should connect to the IP or FQDN of

the workstation, instead of the IP or FQDN of the PCoIP Remote Workstation Card.

Connecting to a PCoIP Remote Workstation Card through the command line

You can have a direct connection to a PCoIP Remote Workstation card, from a PCoIP Software

Client, without requiring a PCoIP Remote Workstation Card agent installed on the host machine if

you connect via the command line by using the  option.

Workstation configuration is required before connecting

If you experience connection problems or degraded performance, make sure that the workstation is configured as

described in Initial Workstation Configuration.



Cloud Access Software Subscription

You need to have a valid Cloud Access Software Subscription to use the PCoIP Remote Workstation Card Agent.



Direct Connection to PCoIP Remote Workstation Cards

PCoIP brokering can now be used to connect to the Remote Workstation Card. You can still connect to a non-

brokered Remote Workstation Card by connecting to the FQDN of the workstation instead of the FQDN of the Remote

Workstation Card. This method of connection requires the PCoIP Remote Workstation Card agent to be installed on

the workstation.



--hard-host

Connecting to a Remote Workstation Card
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Connecting to a remote workstation with a Teradici PCoIP Remote Workstation

Card installed:

1. Double-click the PCoIP Client desktop icon, alias, or program file (PCoIPClient) to launch the

application.

2. In the Host Address and Code box, enter the fully-qualified computer name or IP address of

the Teradici PCoIP Remote Workstation Card installed in the remote workstation. This only

works for direct connection to a legacy firmware releases. For the latest PCoIP Remote

Workstation Card firmware, this must be the address of the broker.

3. Optional: In the Connection Name box, enter a name for your connection. This field accepts

any Unicode character.

4. Click NEXT.

5. If your desktop is locked upon connection and requires you to enter Ctrl+Alt+Delete to log in,

select Connection > Send CTRL-ALT-DEL from the PCoIP Software Client menu bar.

The Connection Information can be saved

If you provide a connection name now, you will have the option of saving the connection after you are

authenticated. Saved connections can be quickly recalled later, without manually re-entering connection

information.



A short interface delay is normal

When a session is first connected, it may take a few seconds before you can take control of the keyboard and

mouse. This is normal behavior.



Connecting to a remote workstation with a Teradici PCoIP Remote Workstation Card installed:
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PCoIP Remote Workstation Card Feature Compatibility

Not all features with the Software Client are fully supported when connecting to a PCoIP Remote

Workstation Card. The following section outlines these limitations against certain features.

Audio: PCoIP Remote Workstation Card uses a hardware based audio protocol which is not fully

supported on the Software Client.

Topology: Single display configuration will work. There may be disruptions in the forms of black

bars or scroll bars on the client if the PCoIP Remote Workstation Card does not support the

display configuration on the client. The worst instance of this disruption will occur for some client

configurations that don't work with the hard host configuration.

USB: Connecting USB devices to the PCoIP Remote Workstation Card is not supported.

Performance: Updated to support PCoIP Ultra are not applicable to the PCoIP Remote Workstation

Card.

PCoIP Remote Workstation Card Feature Compatibility
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Connecting to a USB Device

Remote Windows hosts using the PCoIP Standard Agent or the PCoIP Graphics Agent can use

USB devices that are attached to the client. When you connect a local USB device to your remote

host it will be disabled on the client machine.

USB device connections do not persist across multiple PCoIP sessions. You must connect your

USB device each time you connect.

The following section outlines how to connect a USB device:

1. Attach the USB device you want to connect.

2. Select Connection > USB Devices from the PCoIP Software Client menu.

• A list of USB devices connected to your client machine appears. Integrated USB devices,

such as built-in cameras on laptops, will appear in this list along with devices you have

plugged in yourself.

• Some devices will identify themselves only as USB Device.

3. Click Connect beside the USB device you want to use.

PCoIP Agent needs to be configured to enable USB redirection

The USB menu will only show up if the PCoIP Agent has been configured to enable USB redirection and a USB device

has been detected by the PCoIP Client.



ePadLink Signature Pad and some Wacom tablets are connected via local termination

If you are using an ePadLink Signature Pad and certain Wacom tablets they can be connected via local termination.

You do not need to carry out any other steps to establish this connection. For information on which Wacom tablets

are locally terminated, see Wacom Tablets.



NoMachine USB Driver Compatibility

PCoIP Clients are not compatible with NoMachine and No Machine USB drivers. For information on how to uninstall

NoMachine USB drivers, see here.



Connecting to a USB Device
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Disconnecting a USB Device

1. Select Connection > USB Devices from the PCoIP Software Client menu.

Connecting to Human Interface Devices

Most Human Interface Devices (HIDs), such as keyboards and mice, are automatically handled by the PCoIP Software

Client and don't appear on in this list even if they use a USB connection.

If you need to connect a Human Interface Device that can't be locally processed, like a 3D mouse or a Wacom tablet,

enable the Show Human Interface Devices checkbox to reveal the device in the USB device list and click its Connect

button.

You may also have to complete additional configuration steps or install drivers on the host machine.



Disconnecting a USB Device
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2. Click Disconnect beside the USB device you want to disconnect. 

USB Auto-Forward for Non-HID Devices

A HID is a device class definition that enables a generic USB driver to support devices such as

keyboards, mice, tablets, controllers, etc. Non-HID devices primarily run on the PS/2 port transport.

Automatic bridging enables you to auto bridge all non-HID USB devices by using the 

 command line parameter.

USB Vendor ID/Product ID Auto-Forward

You can automatically forward up to 20 USB devices to the host at the start of the session by

calling the PCoIP client executable with  and the required VID/PID pairs. 

usb-auto-

forward

vidpid-auto-forward

USB Auto-Forward for Non-HID Devices
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Devices that are auto-forwarded will appear in the USB Devices dialog box, enabling users to

connect or disconnect them from the host. The following is an example of how this command

would look with the VID/PID values: 

The following rules apply to VID and PID values:

• VID/PID values are comma-separated: ,

• VID/PID pairs are space-separated:  

• VID/PID pairs with invalid values will be discarded. Discarded rules appear in the event log.

• Up to 20 devices will be passed; if more than 20 are attempted, the first 20 will be accepted

and rest ignored. Ignored rules appear in the event log.

VID/PID Pairs

You can locate the VID/PID pairs from the PCoIP Client logs which are placed in %localappdata%

\Teradici\PCoIPClient\logs. When getting the VID/PID pairs from the log you need to strip 0x from the IDs,

and use the rest of the ID when running the  command. As outlined in the following example: 

The VID/PID pair in this scenario would be 18a5,0302.



vidpid-auto-forward

2040-12-12T20:36:46.117Z e0f9e9e9e-866f-1038-test-ac87a3007abc LVL:2 RC:   0        
MGMT_USB :Device 0x00010001 VID=0x**18a5**PID=0x**0302**
2040-12-12T20:36:46.117Z e0f9e9e9e-866f-1038-test-ac87a3007abc LVL:2 RC:   0        
MGMT_USB :Device 0x00010001 Name=TEST Serial=012345ABCDE pp=000222222

pcoip_client.exe -vidpid-auto-forward "1234,5678 abcd,efgh"

xxx yyy

aaa,bbb ccc,ddd

USB Vendor ID/Product ID Auto-Forward
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Configuring Wacom Tablets

This section outlines how to configure your Wacom tablet through the PCoIP Client session. There

are two available features within the PCoIP Client that can be used to configure the monitor

display and orientation. This only applies to locally terminated Wacom Tablets.

Tablet Monitor

The Tablet Monitor feature enables you to select the monitor you want to use with your Wacom

tablet. You can change between using a pen or mouse and select the orientation position.

To configure Tablet Monitor settings:

1. Select View from the in-session options bar.

2. Check the Tablet Monitor option.

3. Open Wacom Tablet Properties from the Wacom Desktop Center.

4. Select your device, tool and application.

5. Select your screen area from the dropdown menu.

Configuring Wacom Tablets
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Tablet Monitor
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Tablet Orientation Left-handed

The left-handed orientation configures the tablet for a left-handed orientation. Select ExpressKeys

Right for a left-handed orientation, and ExpressKeys Left for a right-handed orientation. Rotate the

tablet to the desired orientation.

To configure Tablet Orientation:

1. Select View from the in-session options bar.

2. Check the Tablet Orientation Left-handed option.

3. Open Wacom Tablet Properties from the Wacom Desktop Center.

4. Select your device, tool and application.

5. Select your orientation from the dropdown menu.

Tablet Orientation Left-handed
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Using Saved Connections

Once you have saved a connection, you can use it to reconnect easily.

To reconnect using your saved connection:

1. Click the button for the saved connection. The button label displays the connection name you

assigned when you configured the connection. 

2. To see the connection address, hover your mouse over the saved connection. Hovering over a

saved virtual desktop will also show the desktop name. 

Using Saved Connections
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3. To edit or delete a saved connection, click the configure button on the right, and then select

the desired option from the popup menu. 

4. If you have saved multiple connections, click the desired one to reconnect. If you have more

than four saved connections, additional saved connection buttons appear in an extended area

of the page. Use the forward and back arrows to navigate between areas. 

5. Any time you wish to connect to a new workstation, just click NEW CONNECTION to return to

the main screen, and then enter the connection details.

To reconnect using your saved connection:
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Disconnecting a Session

To disconnect a PCoIP session from either client, select the Connection > Disconnect menu

option.

Quitting the application will also disconnect the current session.

Session Reconnection

If a network interruption is detected, the PCoIP session enters a reconnecting phase. In this phase

the client will show you the network reconnecting dialog which indicates that there is a network

issue and that the client is trying to reconnect and re-establish the PCoIP session. You can click 

disconnect to cancel the attempted reconnect and disconnect the session completely. If the

reconnection is successful, the notification dialog will disappear and the session will be restored, if

not, the session will be disconnected completely.

Quickly disconnect from a session

To quickly disconnect from a session, press Ctrl + Alt + F12.



Disconnecting a Session
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Changing the PCoIP Software Client Window Mode

You can use the PCoIP Software Client in full-screen or windowed mode. Full-screen mode is

recommended in most cases.

Activating Full Screen Modes

The PCoIP Software Client provides two full-screen modes: one monitor and all monitors.

To switch from windowed mode to full-screen mode:

• To use one full-screen display, select View > Show Fullscreen One Monitor.

All open windows and applications will be moved to a single full-screen display. This is equivalent

to disconnecting all but one monitor from a physical host.

• To use all available full-screen displays, select View > Show Fullscreen All Monitors.

This mode shows full-screen displays on all client monitors.

To switch from Fullscreen One Monitor to Fullscreen All Monitors mode:

1. Reveal the menu bar by moving the mouse cursor to the top of a client display.

2. Select View > Show Fullscreen All Monitors.

To switch from Fullscreen All Monitors to Fullscreen One Monitor mode:

1. Reveal the menu bar by moving the mouse cursor to the top of a client display.

2. Select View > Show Fullscreen One Monitor.

Keyboard shortcut

You can also enter full-screen mode by pressing Ctrl+Alt+Enter while in windowed mode. The shortcut will activate

whichever full-screen mode was used last, or all monitors if no previous selection was made.



Changing the PCoIP Software Client Window Mode
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Minimizing the PCoIP Software Client from a Full-screen Mode

To minimize a software client in full-screen mode:

1. Reveal the menu bar by moving the mouse cursor to the top of any display.

2. Select View > Minimize Client.

Activating Windowed Mode

To switch from full-screen mode to windowed mode:

1. Reveal the menu bar by moving the mouse cursor to the top of any display.

2. Select View > Leave Fullscreen.

Persistent Display Topology

Depending on the display topology mode you have selected, for example Fullscreen One Monitor, if you disconnect

and then reconnect to the session, it will maintain that same mode upon reconnection. The state and mode will be

preserved.



Keyboard shortcut

You can also minimize the client by pressing Ctrl+Alt+m while in any full-screen mode.



Keyboard shortcut

You can also enter windowed mode by pressing Ctrl+Alt+Enter while in any full-screen mode.



Minimizing the PCoIP Software Client from a Full-screen Mode
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Detect Monitors

The detect monitors feature enables you to add and remove displays from the desktop through the

PCoIP Clients while in an active session.

Adding a Display

The following steps outline how to add a display to your desktop through the PCoIP Client:

1. Connect a new monitor to the client.

2. From the desktop, click View.

3. Click Detect Monitors.

The displays on the remote desktop will be extended to include the new monitor.

Removing a Display

The following steps outline how to remove a display from your desktop.

1. Disconnect a monitor from the client.

2. From the desktop, click View.

3. Click Detect Monitors.

You will no longer see the monitor that you have disconnected from the client.

Detect Monitors

© 2020 Teradici 45



Enhanced Audio and Video Synchronization

Enhanced Audio and Video Synchronization (A/V Sync) provides improved full-screen video

playback, reducing the difference in delays between the audio and video channels and smoothing

frame playback on the client. This improves lip sync and reduces video frame drops for movie

playback.

This feature introduces a small lag in user interaction responsiveness when enabled. Using

enhanced audio and video synchronization will reduce the maximum frame rate.

Enhanced A/V Sync is enabled on a per-display basis, so you can dedicate individual displays to

playback without impacting responsiveness on the others.

To turn on A/V Sync:

1. Go to C:\%appdata%\Teradici\Teradici PCoIP Client.ini and add the following line: 

The above text is OS specific. Note the setting changed from 0 to 1 in the 19.11 release of the

PCoIP Client.

2. You need to relaunch the PCoIP Client for this change to take effect.

When enabled, a check mark will appear beside the enhanced A/V Sync menu item on that display.

To use enhanced A/V Sync:

1. If you are in full-screen mode, reveal the menu bar on the display you want to enhance by

moving the mouse cursor to the top of the screen.

2. On the display you want to enhance select View>Enhanced A/V Sync to toggle the enhanced

sync mode.

enable_enhanced_avsync=1

Persistent Display Topology

The Enhanced Audio and Video Synchronization feature is persistent across sessions from the same client, provided

that the display topology has not changed.



Enhanced Audio and Video Synchronization
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Sending a Ctrl-Alt-Del Command

To send the Ctrl-Alt-Del keyboard command to a remote workstation, select the Connection >

Send CTRL-ALT-DEL menu option.

Sending a Ctrl-Alt-Del Command
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Changing the Language

In addition to English, the PCoIP Software Client also supports these languages: Chinese

(Simplified), French, German, Italian, Japanese, Korean, Portuguese (Brazil), Portuguese (Europe),

Russian, Spanish, and Turkish. During installation, you can select one of the supported languages.

To change the language after installation:

In Control Panel > Region and Language > Formats tab, select another language in the Format list.

Changing the Language
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System Precedence

The following section outlines the scope precedence commands between the System Scope and 

User Scope. If you are updating individual user settings then the user scope locations and

parameters can be followed. Due to this order of precedence where by the system scope setting

takes precedence over the user scope setting, a change in the user settings may not take effect if

the system scope setting has been updated.

System Scope

User Scope

To add a new key append key=value to the .ini file:

If you are creating a new file, the format of the file should be:

For example:

%PROGRAMDATA%\Teradici\Teradici PCoIP Client.ini

%APPDATA%\Teradici\Teradici PCoIP Client.ini

[General]
<key>=<value>

[General]
security_mode=2

System Precedence
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PCoIP Client Parameters

The following table outlines command line parameters that are available to use and customize:

Short Long Default Description

-? Display help message. Set to false by default.

-v Print version information. Set to false by default.

-u Username sent to Connection Broker.

-p Password sent to Connection Broker.

-d Domain sent to Connection Broker.

-b Connection broker URL.

-l Unset force log level (will override config/registry)

-w False run inside a window.

-f False run in full-screen mode. The default is to run in windowed mode.

-s Security mode.

- Set locale.

- Disable USB.

- Send relative mouse events when the middle mouse button is pressed.

Do no re-enter the pre-session after leaving the in-session.

Auto-forward all non-HID devices.

String of VID, PID hex values separated by spaces.

help

version

username

password

domain

connection-broker

log-level

windowed

fullscreen

security-mode

locale

disable-usb

send-rel-mouse-on-mmb

quit-after-disconnect

usb-auto-forward

vidpid-auto-forward

PCoIP Client Parameters
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HID Local Termination Blacklist

Local Termination of Wacom tablets provides the best user experience in networks with high

latency, however some features of the tablet may not be fully supported with local termination. A

HID local termination blacklist has been added to override the preferred local termination mode. 

Devices on the blacklist would be bridged to the remote desktop. To enable the HID local

termination blacklist, add the following setting to %APPDATA%\Teradici\Teradici PCoIP Client.ini.

The vendor and product IDs are separated by a comma and multiple devices are separated by a

space.

localtermination_black_list="vid,pid vid2,pid2"

HID Local Termination Blacklist
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High Performance Client

The PCoIP Software Client has a high performance mode that can be enabled through the 

 file. To enable the high performance mode of the PCoIP Client, set

the following value:

Additional information on the high performance client:

• Compatible for fullscreen, all monitors only. You cannot use windowed mode.

• Menus are not available.

• To disconnect use ctrl-alt-F12  on Windows and ctrl-alt-~  on Linux.

• Use the  command on the command line to connect usb peripherals,

such as Wacom, when launching the PCoIP Client. For information on how to use the 

 command, see here.

• You can minimize the client by using ctrl-alt-m .

Teradici PCoIP Client.ini

%appdata%\Teradici\Teradici PCoIP Client.ini

enable_native_opengl=1

vidpid-auto-forward

vidpid-

auto-forward

High Performance Client
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PCoIP Software Client Security Modes

The PCoIP Software Client uses certificates to verify the identity of the host to which it connects.

The security mode is configured by the  setting in the Teradici PCoIP Client

configuration file, which is described next. Three security mode options are available:

• security_mode=0: verification is not required A red, unlocked padlock icon appears on the

client login screen.

• security_mode=1: warn but allow (default) If a certificate cannot be verified, an 'untrusted

server' warning displays and a red, unlocked padlock icon appears on the client login screen.

Users still have the option of connecting.

This mode is used if  is not set in the configuration file.

• security_mode=2: full verification is required Users cannot connect unless a certificate can be

verified.

Setting the Security Mode

Use the following procedure to set the PCoIP Software Client's security mode.

To set the security mode for the PCoIP Software Client:

1. Close the PCoIP Software Client.

2. Open a Windows Explorer window and navigate to %appdata%\Teradici.

3. Using a text editor, open Teradici PCoIP Client.ini.

4. Add the line  to the file, where  is your desired security

option (0, 1, or 2).

security_mode

security_mode

PCoIP sessions are always encrypted

Your PCoIP session is still encrypted and secure if you connect with security mode 0 or 1. The red padlock icon

indicates that the certificate presented by the host is not signed by a trusted certificate authority in the client’s

certificate store, not that the session is insecure.



security_mode=<value> <value>

PCoIP Software Client Security Modes
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5. Save the file.

Setting the Security Mode
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Installing the Internal Root CA Certificate in a PCoIP
Client

Your root CA certificate must be installed in any PCoIP client that will be used to connect to the

PCoIP Agent.

Installing Root CA Certificates in the PCoIP Software Client for
Windows

To import the root CA certificate for the PCoIP Software Client for Windows:

1. Copy your root CA certificate file (*.crt) to a directory reachable by your Windows client.

2. Open the Microsoft Management Console on the agent machine:

a. Press + r  to open the run dialog

b. type mmc and press Enter .

Root CA Certificate must have a .crt extension

You must change the root CA certificate's extension from .pem to .crt before installing it on a PCoIP Software Client.



Windows must trust your root certification authority

When you use your own private key and certificate, you must add your internal root CA certificate to the Windows

Trusted Root Certification Authorities certificate store on the client computer.

Users without a trusted root CA will receive an Unable to get local issuer certificate error and fail to connect.



Active Directory group policies

For information on using Active Directory Group Policy to distribute certificates to client computers, see http://

technet.microsoft.com/en-us/library/cc772491.aspx.



Installing the Internal Root CA Certificate in a PCoIP Client
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3. Add the Certificates snap-in:

a. Select File > Add/Remove Snap-in.

b. Select Certificates from the Available snap-ins list and then click Add.

c. Select My user account and then click Finish.

d. Click OK.

4. Import the root CA certificate:

a. Expand Certificates - Current User.

b. Right-click on Trusted Root Certification Authorities, select All Tasks > Import from the

context menu, and then click Next.

c. Use the Browse button to navigate to the directory where your root CA certificate is

located and select your root CA certificate.

d. Click Open and then Next.

e. Select the option to place all certificates in the Trusted Root Certification Authorities

certificate store.

f. Click Next and then Finish.

g. At the security warning, click Yes.

After the certificate installs successfully, it appears in the Trusted Root Certification Authorities >

Certificates list.

Installing Root CA Certificates in the PCoIP Software Client for Windows
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Contacting Support

If you encounter problems installing or using Teradici technology, you can:

• Check for updated release notes, which may address the issue you are experiencing. Release

notes are published on Teradici Support.

• Browse the Teradici Knowledge Base.

• Submit a support ticket.

Contacting Support
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The Teradici Community Forum

The PCoIP Community Forum allows users to have conversations with other IT professionals to

learn how they resolved issues, find answers to common questions, have peer group discussions

on various topics, and access the Teradici PCoIP Technical Support Service team. Teradici staff

are heavily involved in the forums.

To join the Teradici community, visit the Teradici Community Forum.

The Teradici Community Forum
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Creating a Technical Support File

Teradici may request a support file from your system in order to troubleshoot and diagnose PCoIP

issues.

The support file is a tar.gz archive containing Software Client for Windows for Windows logs and

other diagnostic data that can help support diagnose your problem.

To create a support file:

1. Open a command prompt window as the same Windows user that runs the client.

2. On the command line, run:

The support file will be created and placed in %localappdata%\Teradici\Support. A new

File Explorer window will open with the generated support file selected.

C:\>"Program Files (x86)\Teradici\PCoIP Client\ClientSupportBundler.exe"`

Creating a Technical Support File
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Checking the PCoIP Software Client Software
Release

The PCoIP Software Client pre-session window contains an About button in the lower left of the

window. Click this button and then select About from the popup menu to display the PCoIP

Software Client software release version.

From either client, you can also select the Teradici PCoIP Client > About Teradici PCoIP Client

menu to display the software release version from within a PCoIP session.

Checking the PCoIP Software Client Software Release
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About menu item only appears when the client is in session

The About Teradici PCoIP Client menu item only appears when the client is in session. The menu item is not available

from the pre-session GUI.



Checking the PCoIP Software Client Software Release
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Troubleshooting the Software Client for Windows

This section demonstrates using Software Client for Windows log files to troubleshoot problems

you may encounter with your Software Client for Windows.

Software Client for Windows logs are text (.txt) files that contain system and session information

about your connection. They are useful for troubleshooting problems. A new log file is created

each time you use a Software Client for Windows to initiate a PCoIP session.

Client logs are placed in %localappdata%\Teradici\PCoIPClient\logs.

If you experience a problem, recreate the issue, generate a support bundle and contact Teradici

Support. You can also check the Teradici PCoIP Community Forum for troubleshooting

information about this product.

Troubleshooting the Software Client for Windows
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Session Log IDs

The Software Client for Windows creates a unique session ID when a new session is established,

and distributes that ID to all components in the system. When PCoIP components generate log

messages, they are prefixed by this unique session ID, allowing administrators and support to

easily group events by session across multiple components:

For example:

Log messages that do not pertain to a specific session will show a string of zeroes in place of the

session log ID number.

yyyy-mm-ddThh:mm:ss.ffffffZ xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx > …

2015-11-06T08:01:18.688879Z 4208fb66-e22a-11d1-a7d7-00a0c982c00d > …

Session Log IDs
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Setting Log Levels

You can set log levels to determine the level of details provided in the log. Log levels range from 0

to 3, where 0 provides the least information and 3 provides the most information.

To set log levels:

1. From the command prompt, navigate to C:\Program Files (x86)\Teradici\PCoIP

Client\bin.

2. Enter the following command:

where  is lowercase L and  is desired the log level (1, 2, or 3).

pcoip_client.exe -l x

l x

Setting Log Levels
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Reconnecting a PCoIP Session

If a network interruption is detected, the PCoIP session enters a reconnecting phase. In this phase

the client will show you the network reconnecting dialog which indicates that there is a network

issue and that the client is trying to reconnect and re-establish the PCoIP session. You can click 

disconnect to cancel the attempted reconnect and disconnect the session completely. If the

reconnection is successful, the notification dialog will disappear and the session will be restored, if

not, the session will be disconnected completely.

Reconnecting a PCoIP Session
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